题目描述
按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。
输入
第一行输入元素个数 n (1 <= n <= 15);
第二行输入 n 个整数,保证在 int 范围内。
输出
第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。
样例输入 Copy
10 21 30 14 55 32 63 11 30 55 30
样例输出 Copy
10 30 55 30 11 63 32 55 14 30 21 7 30 55 11 63 32 14 21
#include<stdio.h>
#include<stdlib.h>
struct ss
{
int number;
struct ss *next;
};
void put(struct ss*head,int n)
{ printf("%d\n",n);
struct ss *p=head->next;
while(p)
{
if(p->next)
{
printf("%d ",p->number);
}
else
printf("%d\n",p->number);
p=p->next;
}
}
struct ss*build(struct ss *head,int n)
{
struct ss*q;
int i;
for(i=0;i<n;i++)
{
q=(struct ss*)malloc(sizeof(struct ss));
scanf("%d",&q->number);
q->next=head->next;
head->next=q;
}
return (head);
}
int main( )
{
int n;
struct ss *head;
head=(struct ss*)malloc(sizeof(struct ss));
head->next=NULL;
scanf("%d",&n);
head=build(head,n);
put(head,n);
struct ss *p=head;
while(p->next)
{
p=p->next;
struct ss *q=p,*qi=q->next;
while(qi)
{
if(p->number==qi->number)
{
q->next=qi->next;
free(qi);
qi=q->next;
n--;
}
else
{
qi=qi->next;
q=q->next;
}
}
}
put(head,n);
return 0;
}
文章评论