当前位置:网站首页>About browserlist configuration items

About browserlist configuration items

2021-01-18 15:22:32 Contribute to the cause of coding

browserslist Is an array

"> 1%"                            // Over the world 1% The browser that people use , Browser version selected by global usage statistics .>=, < and <= It can also run .
"> 1% in US"                  // Use us usage statistics . It takes a two letter country code . A list of codes can be found in node_modules/caniuse-lite/data/regions Find .
"> 1% in alt-AS"             // Use Asia's usage statistics . A list of all area codes can be found in node_modules/caniuse-lite/data/regions Find .
"> 1% in my stats"          // Use custom data .
"cover 99.5%"                // Most popular browsers that provide coverage .
"cover 99.5% in US"      // ditto , Two letter country code .
"cover 99.5% in my stats"    // Use custom data .
"maintained node versions" // all Node.js edition , Still by node .js Foundation maintain .
"node 10"  and "node 10.4"        // Choose the latest node .js 10.x.x or 10.4.x edition .
"current node"                       // Browserslist Currently in use node .js edition .
"extends browserslist-config-mycompany" // from browserslist-config-mycompany npm Get the query from the package .
"ie 6-8"                                  // Select a range that contains all versions .
"Firefox > 20"                        // Greater than 20 The updated Firefox edition .>=, < and <= It can also run . It also applies Node.js.
"iOS 7"                                  // Use it directly iOS Browser version 7.
"Firefox ESR"                        // Abreast of the times [Firefox ESR] edition .
"unreleased versions or unreleased Chrome versions"    // alpha and beta Test version .
"last 2 major versions or last 2 ios major versions"          // All secondary / The last two major versions of the patch version .
"since 2015" or "last 2 years"                                              // 2015 year ( It's fine too 2015-03 and 2015-03-10) All versions released since .
"dead"        // Browsers from the last two versions of the query , But it doesn't account for... In global usage statistics 0.5%, also 24 There is no official support or update for months . Now it is IE 10、IE_Mob 10、BlackBerry 10、BlackBerry 7 and OperaMobile 12.1.
"last 2 versions"                 // The last two versions of each browser .
"last 2 Chrome versions"   // Last 2 individual Chrome Browser version .
"defaults"                           // Browserslist Default browser (> 0.5%,last 2 versions,Firefox ESR,not dead).
"not ie <= 8" // Exclude browsers selected by previous queries .
You can add... To any query “not”.

Combination query :

 "or" The combiner can use keywords "or“ It's like ”,“."last 1 version or > 1%" amount to ”last 1 version, > 1%

”and“ Combined queries are also supported to perform the intersection of the previous query :”last 1 version and > 1%“.

Yes 3 There are two different ways to combine queries , As shown below . First , You start with a query , Then we combine these queries to get the final list .

obviously , You can't get from ”not“ The combiner starts , Because there is no left side query to combine it .

or/ , > 5% or last 2 versions 
> 5%, last 2 versions
and > 5% and last 2 versions
not > 5% and not last 2 versions 
> 5% or not last 2 versions 
> 5%, not last 2 versions

 

Last About IE Browser usage ( At home )

have only ie 8 9 10 have only  0.1% The usage rate of

版权声明
本文为[Contribute to the cause of coding]所创,转载请带上原文链接,感谢
https://chowdera.com/2021/01/20210118152130905B.html

随机推荐