当前位置:网站首页>Installation of admkunetk and connetk

Installation of admkunetk and connetk

2020-12-07 08:06:59 osc_ mpdswsal

docker Installed successfully by default .
1. Configure alicloud kubeadm Of yum Source :
cat /etc/yum.repos.d/kubernets.repo
[kubernetes]
name=Kubernetes
baseurl=http://mirrors.aliyun.com/kubernetes/yum/repos/kubernetes-el7-x86_64
enabled=1
gpgcheck=0
2. Start installation :
yum -y install kubelet kubeadm kubectl --disableexcludes=kubernetes
If you want to make a version install , With 1.14 Version as an example :
yum -y install kubelet-1.14.2 kubeadm-1.14.2 kubectl--1.14.2 --disableexcludes=kubernetes










3. If installed , There are two kinds of mistakes :
A wrong :
Error: Package: kubelet-1.19.2-0.x86_64 (kubernetes)
Requires: conntrack
Error 2 :
Error: Package: kubelet-1.14.2-0.x86_64 (kubernetes)
Requires: kubernetes-cni = 0.7.5





resolvent : download yum Source , Install dependency packages
cd /etc/yum.repos.d/
wget http://mirrors.aliyun.com/repo/epel-7.repo
wget http://mirrors.aliyun.com/repo/Centos-7.repo
yum install epel-release
yum install conntrack-tools




版权声明
本文为[osc_ mpdswsal]所创,转载请带上原文链接,感谢
https://chowdera.com/2020/12/20201207080044156c.html