当前位置:网站首页>明年起旧版本安卓设备将无法浏览大约30%的网页

明年起旧版本安卓设备将无法浏览大约30%的网页

2020-11-09 16:06:59 宗恩

image

现在大多数网络都使用HTTPS来安全传输信息,这得益于谷歌公司的推动。然而,这也意味着,如果你的设备上没有安装适当的证书,许多网站的浏览可能会遇到问题,或者完全无法加载页面。可怕的是这种情况,明年将发生在安装旧版本安卓系统的设备上。

Let's Encrypt 宣布,其服务使用的一个由 IdenTrust 提供的根证书将于 2021 年 9 月 1 日到期。Let's Encrypt 用自己的名为 ISRG Root X1 的根证书为到期做好了准备,虽然它在很多设备上都得到了支持,但存在一个问题:「由于Android系统更新缓慢,数百万运行Android7.1.1以下版本的设备将无法使用Let's Encrypt证书连接网站。」


Let's Encrypt 是全球领先的证书颁发机构(CA),该集团的证书被大约30%的网站域名使用。在成立之初该机构就申请了自己的 ISRG Root X1 根证书,让所有的浏览器和操作系统都能收录。

这里我们简单介绍下证书解决的信任问题是什么?

借用网上的例子:假如你供职于X公司,老板让你去拜访A公司老总谈点业务,此时你直接去,可能前台会把你挡住,因为没人认识你,那怎么办?你发现C公司跟A公司业务往来密切,你对C公司也熟悉,你就去找C公司的老板给你写了封介绍信并且盖上C公司章,然后你拿着介绍信去A公司,把介绍信给前台一看,前台看到C公司的章就信任你了,就让你去拜访了。证书就是介绍信,通过盖章的方式来解决信任问题。

此前 Let's Encrypt 所有的证书都与IdenTrust(一家证书颁发机构)的 DST Root X3 根证书交叉签署,证书也已经在Windows、macOS、Android和其他大多数软件平台上使用多年。

但 Let's Encrypt 与 IdenTrust 的合作关系将于 2021 年 9 月 1 日到期,IdenTrust 并不打算再签订交叉签名协议。这意味着,所有没有 Let's Encrypt 根证书的浏览器和操作系统将无法再与使用该集团证书的网站和服务合作。


虽然该协议要到明年9月才结束,但默认情况下,加密将从2021年1月11日开始停止交叉签名。对于站点和服务,该选项将仍然存在,以继续生成交叉签名的证书,但仅持续到9月1日。

旧版Android设备的唯一解决方法是安装Firefox浏览器,该浏览器使用其自己的包含ISRG根目录的证书存储。但是,这不能防止浏览器外部的应用程序和其他功能损坏。

image.png

版权声明
本文为[宗恩]所创,转载请带上原文链接,感谢
https://segmentfault.com/a/1190000037773514