当前位置:网站首页>Configure switch trunk interface traffic local priority forwarding (cluster / stack)

Configure switch trunk interface traffic local priority forwarding (cluster / stack)

2020-11-09 11:08:55 Nankong City

Networking graph

Eth-Trunk Introduction to local priority forwarding of interface traffic

  • In the device cluster / In the case of stacking , In order to ensure the reliable transmission of traffic , The output interface of the traffic is set to Eth-Trunk Interface . that Eth-Trunk There must be cross frame member ports in the interface . When clustering / When stacking devices forward traffic ,Eth-Trunk Interface by HASH The algorithm may select cross box member ports . Due to cluster / Limited Cable bandwidth between stacking devices , Cross frame forwarding traffic increases the bandwidth bearing pressure between cluster devices , At the same time, it also reduces the efficiency of traffic forwarding . To solve this problem , You can make Eth-Trunk Interface traffic local priority forwarding .

Configuration considerations

  • If the device Eth-Trunk The bandwidth of the active interface is enough to carry the traffic forwarded by the device , You can make Eth-Trunk Interface traffic local priority forwarding function , Avoid low forwarding efficiency 、 The problem of high bandwidth load between cluster devices .
  • If the device Eth-Trunk The bandwidth of the active interface cannot carry the traffic forwarded by the device , Need to make it possible Eth-Trunk Interface traffic local priority forwarding function , At this time, part of the flow of the device will choose cross device Eth-Trunk Outgoing interface forwarding , To prevent packet loss .

Networking requirements

  • Pictured 1 Shown , In order to increase the capacity of the equipment, the cluster technology is adopted , take Switch3 and Switch4 Linked through dedicated cluster cables , It is presented as a logical switch . In order to achieve backup between devices 、 Improve reliability , Using cross cluster devices Eth-Trunk Interface technology , Add physical interfaces on different devices to the same Eth-Trunk Interface . Without any fault in the network , stay PE When viewing the member port information on the device , Find out VLAN2 The data flow will pass through the member port GE1/0/1 and GE1/0/2 forward ,VLAN3 Of data traffic through the member port GE1/0/1 and GE1/0/2 forward . It increases the bandwidth carrying capacity between cluster devices , It also reduces the efficiency of traffic forwarding .
  • In order to effectively guarantee VLAN2 Of data traffic through the member port GE1/0/1 forward ,VLAN3 Of data traffic through the member port GE1/0/2 forward , Enable on cluster devices Eth-Trunk Interface traffic local priority forwarding function .

Configuration ideas

  • establish Eth-Trunk Interface .
  • Join in Eth-Trunk Member interface of .
  • Can make Eth-Trunk Interface traffic local priority forwarding function .
  • Configure each interface and add the corresponding VLAN, Realize the interworking between the two layers .

Operation steps

  • establish Eth-Trunk Interface , And configure the allowed VLAN

  # Configure clusters / Stack switches CSS.

<HUAWEI> system-view
[HUAWEI] sysname CSS
[CSS] interface eth-trunk 10 // Create and enter Eth-Trunk10 Interface .
[CSS-Eth-Trunk10] port link-type trunk  // The configuration interface type is Trunk.
[CSS-Eth-Trunk10] port trunk allow-pass vlan all // The configuration interface allows all of the VLAN.
[CSS-Eth-Trunk10] quit

   # Configure the aggregation switch PE.

<HUAWEI> system-view
[HUAWEI] sysname PE
[PE] interface eth-trunk 10 // Create and enter Eth-Trunk10 Interface .
[PE-Eth-Trunk10] port link-type trunk // The configuration interface type is Trunk.
[PE-Eth-Trunk10] port trunk allow-pass vlan all // The configuration interface allows all of the VLAN.
[PE-Eth-Trunk10] quit
  •   Join in Eth-Trunk Member interface of

  # Configure clusters / Stack switches CSS.

[CSS] interface gigabitethernet 1/1/0/4
[CSS-GigabitEthernet1/1/0/4] eth-trunk 10 // Interface GE1/1/0/4 Add to Eth-Trunk10 in .
[CSS-GigabitEthernet1/1/0/4] quit
[CSS] interface gigabitethernet 2/1/0/4
[CSS-GigabitEthernet2/1/0/4] eth-trunk 10 // Interface GE2/1/0/4 Add to Eth-Trunk10 in .
[CSS-GigabitEthernet2/1/0/4] quit

   # Configure the aggregation switch PE.

[PE] interface gigabitethernet 1/0/1
[PE-GigabitEthernet1/0/1] eth-trunk 10 // Interface GE1/0/1 Add to Eth-Trunk10 in .
[PE-GigabitEthernet1/0/1] quit
[PE] interface gigabitethernet 1/0/2 
[PE-GigabitEthernet1/0/2] eth-trunk 10 // Interface GE1/0/2 Add to Eth-Trunk10 in .
[PE-GigabitEthernet1/0/2] quit
  •   In clusters / Stack switches CSS On enabling Eth-Trunk Interface traffic local priority forwarding function
[CSS] interface eth-trunk 10
[CSS-Eth-Trunk10] local-preference enable // Can make Eth-Trunk10 Interface traffic local priority forwarding function .
[CSS-Eth-Trunk10] quit
  •   Configure layer 2 forwarding function

  # Configure clusters / The stack CSS.

[CSS] vlan batch 2 3
[CSS] interface gigabitethernet 1/1/0/3
[CSS-GigabitEthernet1/1/0/3] port link-type trunk
[CSS-GigabitEthernet1/1/0/3] port trunk allow-pass vlan 2
[CSS-GigabitEthernet1/1/0/3] quit
[CSS] interface gigabitethernet 2/1/0/3
[CSS-GigabitEthernet2/1/0/3] port link-type trunk
[CSS-GigabitEthernet2/1/0/3] port trunk allow-pass vlan 3
[CSS-GigabitEthernet2/1/0/3] quit

   # Configure the access switch Switch1.

<HUAWEI> system-view
[HUAWEI] sysname Switch1
[Switch1] vlan 2
[Switch1-vlan2] quit
[Switch1] interface gigabitethernet 1/0/1
[Switch1-GigabitEthernet1/0/1] port link-type trunk
[Switch1-GigabitEthernet1/0/1] port trunk allow-pass vlan 2
[Switch1-GigabitEthernet1/0/1] quit
[Switch1] interface gigabitethernet 1/0/2
[Switch1-GigabitEthernet1/0/2] port link-type trunk
[Switch1-GigabitEthernet1/0/2] port trunk allow-pass vlan 2
[Switch1-GigabitEthernet1/0/2] quit

   # Configure the access switch Switch2.

<HUAWEI> system-view
[HUAWEI] sysname Switch2
[Switch2] vlan 3
[Switch2-vlan3] quit
[Switch2] interface gigabitethernet 1/0/1
[Switch2-GigabitEthernet1/0/1] port link-type trunk
[Switch2-GigabitEthernet1/0/1] port trunk allow-pass vlan 3
[Switch2-GigabitEthernet1/0/1] quit
[Switch2] interface gigabitethernet 1/0/2
[Switch2-GigabitEthernet1/0/2] port link-type trunk
[Switch2-GigabitEthernet1/0/2] port trunk allow-pass vlan 3
[Switch2-GigabitEthernet1/0/2] quit
  •   Check the configuration results

   After the above configuration is successful , Execute commands in any view display trunkmembership eth-trunk, You can see Eth-Trunk Interface member port information . for example :
   To cluster / Stack switches CSS For example .

<CSS> display trunkmembership eth-trunk 10
Trunk ID: 10
Used status: VALID
TYPE: ethernet
Working Mode : Normal
Number Of Ports in Trunk = 2
Number Of Up Ports in Trunk = 2
Operate status: up

Interface GigabitEthernet1/1/0/4, valid, operate up, weight=1
Interface GigabitEthernet2/1/0/4, valid, operate up, weight=1

 

版权声明
本文为[Nankong City]所创,转载请带上原文链接,感谢