当前位置:网站首页>配置交换机Trunk接口流量本地优先转发(集群/堆叠)

配置交换机Trunk接口流量本地优先转发(集群/堆叠)

2020-11-09 11:08:55 南空城

组网图形

Eth-Trunk接口流量本地优先转发简介

  • 在设备集群/堆叠情况下,为了保证流量的可靠传输,流量的出接口设置为Eth-Trunk接口。那么Eth-Trunk接口中必定存在跨框成员口。当集群/堆叠设备转发流量时,Eth-Trunk接口通过HASH算法可能会选择跨框的成员口。由于集群/堆叠设备间线缆带宽有限,跨框转发流量增加了集群设备之间的带宽承载压力,同时也降低了流量转发效率。为了解决这个问题,可以使能Eth-Trunk接口流量本地优先转发。

配置注意事项

  • 如果本设备Eth-Trunk的活动接口的带宽足以承载本设备转发的流量,可以使能Eth-Trunk接口流量本地优先转发功能,避免转发效率低、集群设备之间的带宽承载压力大的问题。
  • 如果本设备Eth-Trunk的活动接口的带宽不能承载本设备转发的流量,需要去使能Eth-Trunk接口流量本地优先转发功能,此时本设备的部分流量就会选择跨设备的Eth-Trunk出接口转发,防止发生丢包。

组网需求

  • 如图1所示,为了增加设备的容量采用设备集群技术,将Switch3和Switch4通过专用的集群电缆链接起来,对外呈现为一台逻辑交换机。为了实现设备间的备份、提高可靠性,采用跨集群设备Eth-Trunk接口技术,将不同设备上的物理接口加入同一个Eth-Trunk接口。在网络无任何故障情况下,在PE设备上查看成员口信息时,发现VLAN2的数据流量会通过成员口GE1/0/1和GE1/0/2转发,VLAN3的数据流量通过成员口GE1/0/1和GE1/0/2转发。增加了集群设备之间的带宽承载能力,也降低了流量转发效率。
  • 为了有效保证VLAN2的数据流量通过成员口GE1/0/1转发,VLAN3的数据流量通过成员口GE1/0/2转发,可在集群设备上使能Eth-Trunk接口流量本地优先转发功能。

配置思路

  • 创建Eth-Trunk接口。
  • 加入Eth-Trunk的成员接口。
  • 使能Eth-Trunk接口流量本地优先转发功能。
  • 配置各接口加入相应VLAN,实现二层互通。

操作步骤

  • 创建Eth-Trunk接口,并配置允许通过的VLAN

  # 配置集群/堆叠交换机CSS。

<HUAWEI> system-view
[HUAWEI] sysname CSS
[CSS] interface eth-trunk 10 //创建并进入Eth-Trunk10接口。
[CSS-Eth-Trunk10] port link-type trunk  //配置接口类型为Trunk。
[CSS-Eth-Trunk10] port trunk allow-pass vlan all //配置接口允许通过所有VLAN。
[CSS-Eth-Trunk10] quit

   # 配置汇聚交换机PE。

<HUAWEI> system-view
[HUAWEI] sysname PE
[PE] interface eth-trunk 10 //创建并进入Eth-Trunk10接口。
[PE-Eth-Trunk10] port link-type trunk //配置接口类型为Trunk。
[PE-Eth-Trunk10] port trunk allow-pass vlan all //配置接口允许通过所有VLAN。
[PE-Eth-Trunk10] quit
  •  加入Eth-Trunk的成员接口

  # 配置集群/堆叠交换机CSS。

[CSS] interface gigabitethernet 1/1/0/4
[CSS-GigabitEthernet1/1/0/4] eth-trunk 10 //将接口GE1/1/0/4加入到Eth-Trunk10中。
[CSS-GigabitEthernet1/1/0/4] quit
[CSS] interface gigabitethernet 2/1/0/4
[CSS-GigabitEthernet2/1/0/4] eth-trunk 10 //将接口GE2/1/0/4加入到Eth-Trunk10中。
[CSS-GigabitEthernet2/1/0/4] quit

   # 配置汇聚交换机PE。

[PE] interface gigabitethernet 1/0/1
[PE-GigabitEthernet1/0/1] eth-trunk 10 //将接口GE1/0/1加入到Eth-Trunk10中。
[PE-GigabitEthernet1/0/1] quit
[PE] interface gigabitethernet 1/0/2 
[PE-GigabitEthernet1/0/2] eth-trunk 10 //将接口GE1/0/2加入到Eth-Trunk10中。
[PE-GigabitEthernet1/0/2] quit
  •  在集群/堆叠交换机CSS上使能Eth-Trunk接口流量本地优先转发功能
[CSS] interface eth-trunk 10
[CSS-Eth-Trunk10] local-preference enable //使能Eth-Trunk10接口流量本地优先转发功能。
[CSS-Eth-Trunk10] quit
  •  配置二层转发功能

  # 配置集群/堆叠CSS。

[CSS] vlan batch 2 3
[CSS] interface gigabitethernet 1/1/0/3
[CSS-GigabitEthernet1/1/0/3] port link-type trunk
[CSS-GigabitEthernet1/1/0/3] port trunk allow-pass vlan 2
[CSS-GigabitEthernet1/1/0/3] quit
[CSS] interface gigabitethernet 2/1/0/3
[CSS-GigabitEthernet2/1/0/3] port link-type trunk
[CSS-GigabitEthernet2/1/0/3] port trunk allow-pass vlan 3
[CSS-GigabitEthernet2/1/0/3] quit

   # 配置接入交换机Switch1。

<HUAWEI> system-view
[HUAWEI] sysname Switch1
[Switch1] vlan 2
[Switch1-vlan2] quit
[Switch1] interface gigabitethernet 1/0/1
[Switch1-GigabitEthernet1/0/1] port link-type trunk
[Switch1-GigabitEthernet1/0/1] port trunk allow-pass vlan 2
[Switch1-GigabitEthernet1/0/1] quit
[Switch1] interface gigabitethernet 1/0/2
[Switch1-GigabitEthernet1/0/2] port link-type trunk
[Switch1-GigabitEthernet1/0/2] port trunk allow-pass vlan 2
[Switch1-GigabitEthernet1/0/2] quit

   # 配置接入交换机Switch2。

<HUAWEI> system-view
[HUAWEI] sysname Switch2
[Switch2] vlan 3
[Switch2-vlan3] quit
[Switch2] interface gigabitethernet 1/0/1
[Switch2-GigabitEthernet1/0/1] port link-type trunk
[Switch2-GigabitEthernet1/0/1] port trunk allow-pass vlan 3
[Switch2-GigabitEthernet1/0/1] quit
[Switch2] interface gigabitethernet 1/0/2
[Switch2-GigabitEthernet1/0/2] port link-type trunk
[Switch2-GigabitEthernet1/0/2] port trunk allow-pass vlan 3
[Switch2-GigabitEthernet1/0/2] quit
  •  检查配置结果

  上述配置成功后,在任意视图下执行命令display trunkmembership eth-trunk,可以看到Eth-Trunk接口的成员口信息。例如:
  以集群/堆叠交换机CSS的显示为例。

<CSS> display trunkmembership eth-trunk 10
Trunk ID: 10
Used status: VALID
TYPE: ethernet
Working Mode : Normal
Number Of Ports in Trunk = 2
Number Of Up Ports in Trunk = 2
Operate status: up

Interface GigabitEthernet1/1/0/4, valid, operate up, weight=1
Interface GigabitEthernet2/1/0/4, valid, operate up, weight=1

 

版权声明
本文为[南空城]所创,转载请带上原文链接,感谢
https://www.cnblogs.com/zhangwencheng/p/13947460.html